支持平台

The following platforms are supported in Qt 6.1. For information about prior Qt releases, please consult the relevant version in the Qt 文档编制存档 .

Supported platforms are actively maintained, subjected to testing, and bugs discovered in these platforms are prioritized for correction. Significant errors discovered in testing can impact release dates.

The Qt Company offers commercial support for all officially supported platforms and configurations.

Configurations not listed below are not officially supported by the Qt Project. However, Qt may still run on unsupported platforms and configurations. The Qt Company, Qt partners, open source developers, and community users are able to provide assistance in this situation.

注意: Support for specific configurations or operating system versions may end before the support for Qt 6.1 does. A subsequent patch release of Qt 6.1 may drop support for a configuration or replace it with a currently-supported version.

桌面平台

Linux/X11

分发 体系结构 编译器 注意事项
CentOS Linux 8.3 x86_64 GCC 9
openSUSE 15.2 x86_64 GCC 9
SUSE Linux Enterprise Server 15 SP2 x86_64 GCC 10
Ubuntu 20.04 x86_64 GCC as provided by Canonical, GCC 9.x
一般 Linux x86 and x86_64 GCC 9

macOS

目标平台 体系结构 构建环境
macOS 10.14, 10.15, 11.0 x86_64 and x86_64h Xcode 12 (11.1 SDK)

Windows

操作系统 体系结构 编译器
Windows 10 x86_64 MSVC 2019, MinGW 8.1

移动平台

Android

分发 体系结构 编译器 注意事项
Android 6.0 or later (API level 23 or higher) armv7a , x86 , arm64-v8 ,和 x86_64 Clang 11.0.5 (NDK r22b), Clang 9.0.8 (NDK r21) and Clang 8.0.7 (NDK r20b) as provided by Google, MinGW 8.1

iOS

目标平台 体系结构 构建环境 注意事项
iOS 13, iOS 14 armv8 ( arm64 ) Xcode 12 (iOS 14 SDK)

嵌入式平台

嵌入式 Linux

Refer to 配置嵌入式 Linux 设备 for information on generic cross-compilation of Qt for Embedded Linux devices.

For further embedded platform support, please consult the Qt for Device Creation 文档编制。

包的可用性

You can download the Qt installers and source packages from the 下载 页面。更多信息,拜访 Qt 快速入门 页面。

注意: All the supported configurations are not provided as binary packages in the Qt installer. However, the intention is to provide the most widely-used configurations for the developer's convenience.

注意: Linux binary packages are linked against glibc 2.28. If you are using a glibc version older than that you need to build Qt from sources or upgrade glibc to 2.28 or newer.

异常

单个模块可能只在某些平台上是可用的,或者它们可能不支持所有配置。例如,由于 Qt WebEngine 拥有 Chromium 作为第 3 方依赖,因此上游平台或配置的局限性也适用于 Qt WebEngine。

各模块的文档编制均包含模块来自通用平台和配置支持的任何异常的详细信息,如本页所述。

Qt 应用程序的部署

各平台的部署过程是不同的,且其平台页面有更详细描述。同时,还有部署文章概括了一般部署过程。

支持的 Qt 版本

版本 发行日期 标准支持直到 扩展支持可用性
5.0 (5.0.1) 2012-12-19 Ended Yes
5.1 (5.1.1) 2013-07-03 Ended Yes
5.2 (5.2.1) 2013-12-12 Ended Yes
5.3 (5.3.2) 2014-05-20 Ended Yes
5.4 (5.4.2) 2014-12-10 Ended Yes
5.5 (5.5.1) 2015-07-01 Ended Yes
5.6 (5.6.3) 2016-03-16 Ended Yes
5.7 (5.7.1) 2016-06-16 Ended Yes
5.8 2017-01-23 Ended Yes
5.9 (5.9.9) 2017-05-31 Ended Yes
5.10 (5.10.1) 2017-11-30 Ended Yes
5.11 (5.11.3) 2018-05-22 Ended Yes
5.12 (5.12.10) LTS 2018-12-05 2021-12-05 Yes
5.13 2019-06-19 2020-06-19 Ended
5.14 2019-12-12 2020-12-12 Ended
5.15 LTS 2020-05-26 2023-05-26 Yes
6.0 2020-12-08 2021-12-08 Yes

请注意,Qt 是按原样提供的,没有任何种类的担保,我们的产品是没有错误或 Bug 自由的。在适用法律允许的最大范围内,Qt 公司代表自身及其供应商,拒绝任何明示或暗示的担保和条件,包括但不限于对许可软件的适销性、特定目的适用性,冠名和不侵权的隐含担保。